What Are the Technical Requirements for EmbedPress?

We highly recommend that any website using PublishPress also uses PHP 5.6.

Why PHP 5.6? Because PHP itself does not support anything lower than 5.6. Click here for more details on PHP version support. Any version of PHP before 5.6 doesn’t have security updates and will not keep your site safe.

WordPress officially recommends that you use PHP 7.

Does my site meet the PHP requirements?

If you are unsure of what version of PHP your site is using, you can use the “WordPress phpinfo()” plugin to find out.

  • After installing the WordPress phpinfo() plugin, click “Settings” and then “PHP Info”:
  • You will now see your site’s technical details:

Other recommendations

  • Database: MySQL version 5.6 or greater or MariaDB version 10.0 or greater.
  • Server: We recommend Apache or Nginx as the most robust and secure server for running WordPress, but any server that supports PHP and MySQL will do.

For the official WordPress recommendations, please check here.

in Getting Started

Related Articles

Start today!

[i]
[i]